Non riesco a riprodurre i video scaricati da youtube,

15 risposte [Ultimo messaggio]
Ritratto di pabform
pabform
(Junior)
Offline
Junior
Iscritto: 27/03/2014
Messaggi: 26

mi mancano dei codec ma non riesco a trovarli nè ad individuarli. Il formato dei video è mp4 mi ha segnalato che manca un codec che sono andato a cercare sul centro di controllo ma non me l'ha trovato, purtroppo non mi sono marcato il nome e non mi ricordo come si chiama. In un altro forum mi hanno detto che mageia si appoggia a gstreamer faat, mi pare ma neppure per quello ho avuto esito positivo nella ricerca Qualcuno saprebbe dirmi come riuscire a riprodurre mp4, o che programma ci vuole che supporti questo tipo di file? Grazie

Mageia 4 cauldron, PCLinuxOS, Linux ManjaroKDE, LinuxMintPetra Cinammon, UbuntuGnome,
FedoraHeinsburg 20.1, Majonix 1.1, LXSElINUXLTS, OpenSuse Bottle, OpenMandriviaLx, Windows 7 Home Premium 64 bit.

Siamo ciò che pensiamo...

Ritratto di pabform
pabform
(Junior)
Offline
Junior
Iscritto: 27/03/2014
Messaggi: 26

Il file da cercare è il "Decoder MPEG -4 AAC. Sto scrivendo da Manjaro e i video vengono regolarmente riprodotti con dragon player. Lo stesso non avviene in mageia.

Mageia 4 cauldron, PCLinuxOS, Linux ManjaroKDE, LinuxMintPetra Cinammon, UbuntuGnome,
FedoraHeinsburg 20.1, Majonix 1.1, LXSElINUXLTS, OpenSuse Bottle, OpenMandriviaLx, Windows 7 Home Premium 64 bit.

Siamo ciò che pensiamo...

Ritratto di killer1987
killer1987
(Webmaster)
Offline
Webmaster
Iscritto: 02/05/2011
Messaggi: 668

ciao,

puoi installare i codec molto semplicemente aprendo Mageia Welcome e andando nella scheda Applicazioni. fammi sapere

ciao
Marcello

Alé Mageia, C'mon Mageia!!! SAMSUNG RC530, Nvidia GM5400, stamp HP Laserjet 1018, scanner Epson Perfection 3490

Ritratto di pabform
pabform
(Junior)
Offline
Junior
Iscritto: 27/03/2014
Messaggi: 26

Allora, ho fatto come mi hai suggerito Marcello, ho intsllato i codec audio e video, ma il decoder MPEG -4 AAC non viene rilevato dal programma installazioni e aggiornamenti. Ho provato con dragon player che sugli altri sistemi riproduce senza problemi video di ogni tipo, ho provato anche con banshee, ma con lo stesso risultato. Per installare questo codec dovrò andare su internet e scaricarlo a mano, per così dire, e vedere se mi riesce installarlo così. Purtroppo non c'è altra strada, a meno che non me ne suggerisci una tu...non mi restano alternative. E' strano che mageia non rilevi il codec di cui sopra, e che non riproduca video, soprattutto. E' il primo bug noioso davvero che trovo su mageia, spero di risolvere. Ora provo a scaicare il codec e spero di riuscire a trovarlo in formato rpm in modo da poterlo installare senza problemi. Se hai qualche idea fammelo sapere. Ti ringrazio, per adesso

Mageia 4 cauldron, PCLinuxOS, Linux ManjaroKDE, LinuxMintPetra Cinammon, UbuntuGnome,
FedoraHeinsburg 20.1, Majonix 1.1, LXSElINUXLTS, OpenSuse Bottle, OpenMandriviaLx, Windows 7 Home Premium 64 bit.

Siamo ciò che pensiamo...

Ritratto di pabform
pabform
(Junior)
Offline
Junior
Iscritto: 27/03/2014
Messaggi: 26

Niente da fare. per installare il pacchetto mi dice che c'è bisogno delle dipendenze, e quando ne trovo una, subito ne servono altre relative al nuovo file, è un'ora che vado avanti così, a scaricare dipendenze su dipendenze, che non accennano a stabilizzarsi nè a terminare. E' un cane che si mastica la coda, così non arriverò a niente. Credo che dovrò rinunciare all'ascolto della musica su mageia, non vedo alternative attuabili. Ad ogni dipendenza installata se ne aggiungono due o tre da cercare ed installare, sono già più di venti files rpm. Poi mi fa rabia il fatto che sugli altri sistemi funziona tutto, nn me lo spiego e questo mi manda ancora più in bestia. Io ho terminato le risorse, se hai qualche idea tu, sennò mollo qui e ci rinuncio. anche se ,i piange il cuore.. Dacchè ho messo su mageia sono riuscito ad installare solo il driver della stampante, chrome, e qualche altra cosina mi spiace perchè e effettivamente non ci sono ragioni per un comportamento così da parte del sistema. Vedremo gli sviluppi, per ora sono bloccato.

Mageia 4 cauldron, PCLinuxOS, Linux ManjaroKDE, LinuxMintPetra Cinammon, UbuntuGnome,
FedoraHeinsburg 20.1, Majonix 1.1, LXSElINUXLTS, OpenSuse Bottle, OpenMandriviaLx, Windows 7 Home Premium 64 bit.

Siamo ciò che pensiamo...

Ritratto di killer1987
killer1987
(Webmaster)
Offline
Webmaster
Iscritto: 02/05/2011
Messaggi: 668

scusa, mi vuoi dire che dopo aver installato task-codec-audio (e per i video task-codec-video) tramite Installa e rimuovi software non si apre ancora il video? guarda questa guida, prova Vlc (ha i codec integrati) e installa anche questi:

libxine2-codecs k3b-codecs ffmpeg lame gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-ugly-orig-addon gstreamer-0_10-plugins-ffmpeg libdvdcss2

installa tutto da konsole per fare prima, diventa root con "su -" e poi digiti:

urpmi nomepacchetto

fammi sapere

ciao
Marcello

Alé Mageia, C'mon Mageia!!! SAMSUNG RC530, Nvidia GM5400, stamp HP Laserjet 1018, scanner Epson Perfection 3490

Ritratto di pabform
pabform
(Junior)
Offline
Junior
Iscritto: 27/03/2014
Messaggi: 26

Ciao, ho seguito letteralmente quello che hai scritto sulla guida di wiky ed ho installato anche quelli che mi hai consigliato direttament sul forum, ossia libxine2-codecs k3b-codecs ffmpeg lame gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-ugly-orig-addon gstreamer-0_10-plugins-ffmpeg libdvdcss2, ma ancora non sento niente, vedo il video regolarmente ma non sento una nota. Forse devo riavviare, ora riavvio e poi ti dico.
--------------------------------------
Macchè, non si sente niente. Ti allego i messaggi che mi dà il sistema:

Attached images:

Mageia 4 cauldron, PCLinuxOS, Linux ManjaroKDE, LinuxMintPetra Cinammon, UbuntuGnome,
FedoraHeinsburg 20.1, Majonix 1.1, LXSElINUXLTS, OpenSuse Bottle, OpenMandriviaLx, Windows 7 Home Premium 64 bit.

Siamo ciò che pensiamo...

Ritratto di killer1987
killer1987
(Webmaster)
Offline
Webmaster
Iscritto: 02/05/2011
Messaggi: 668

ok, colpa mia Wink alcuni pacchetti hanno cambiato nome nel tempo o dal passaggio da mandriva a mageia.. invece di installarli da terminal vai su Installa e rimuovi software, togli il filtro per i pacchetti GUI e cerchi per parole chiave come gstreamer (trovi un meta-pacchetto chiamato decoders, poi ugly, bad, lame e tanti altri, puoi installarne quanti ne vuoi tanto sono leggeri e non causano problemi al computer), task-codec-audio, libdvd (e installi css2, read4, nav4). adesso dovresti avere davvero risolto, fammi sapere e dammi buone notizie Wink

ciao
Marcello

Alé Mageia, C'mon Mageia!!! SAMSUNG RC530, Nvidia GM5400, stamp HP Laserjet 1018, scanner Epson Perfection 3490

Ritratto di pabform
pabform
(Junior)
Offline
Junior
Iscritto: 27/03/2014
Messaggi: 26

ho installato tutti i gstreamer a disposizione e li ha installati, non ha voluto installare nav4, read 4 e css2 invece. Risultato: scena muta, video presenti ma audio totalmente assente Inutile dirti che ho regolato l'audio di pulseaudio in maniera ottimale, ma non è servito. Come mai queste storie...la faccenda si fa pesante, anche perchè non so come agire, non so cosa installare, come e quando insomma una situazione che non mi era mai capitata, men che mai con Miles Davis. Il non sapere cosa c'è che non va mi mette agitazione,

Mageia 4 cauldron, PCLinuxOS, Linux ManjaroKDE, LinuxMintPetra Cinammon, UbuntuGnome,
FedoraHeinsburg 20.1, Majonix 1.1, LXSElINUXLTS, OpenSuse Bottle, OpenMandriviaLx, Windows 7 Home Premium 64 bit.

Siamo ciò che pensiamo...

Ritratto di killer1987
killer1987
(Webmaster)
Offline
Webmaster
Iscritto: 02/05/2011
Messaggi: 668

ma scusa, non si sente solo un particolare filmato oppure l'audio è completamente assente? gli mp3 funzionano? i filmati .avi vanno? sei sicuro che non sia quel particolare file ad essere non funzionante? MAI avuto problemi di audio e/o video con mandriva prima e con mageia poi, mi sembra parecchio strano... hai provato ad eseguire i file con vlc? come vanno?

Alé Mageia, C'mon Mageia!!! SAMSUNG RC530, Nvidia GM5400, stamp HP Laserjet 1018, scanner Epson Perfection 3490

Ritratto di pabform
pabform
(Junior)
Offline
Junior
Iscritto: 27/03/2014
Messaggi: 26

E' come ti ho detto Marcello, l'audio è completamente assente nei video scaricati da youtube con il software youtube-dl. Quello che mi lascia davvero perplesso è che negli altri sistemi operativi che ho si sente perfettamente, ne ho provati svariati, sia MintPetra16 che PCLinuxOS che Ubuntu e Mandriva. Sembra che a Mageia manchi qualcosa ma cosa, che ho installato tutto quello che mi hai consigliato. Forse, mi viene da pensare, dipende dal fatto che non ho ancora scaricato i drivers Nvidia che non ho installato per evitare che si impiantasse...non mi viene in mente altro per adesso.
VLC è il mio lettore di default, lo uso sempre, anche per fare video oltre che per riprodurli, e su mageia appena clicco sul video che vorrei riprodurre appare il messaggio che ti mandai, messaggio che mi lascia molto perplesso.
I files MP3 vanno, gli AVI pure, con gli MP4 invece appare il seguente messaggio "Nessun modulo decodifica appropriato:
VLC non supporta il formato audio o video "mp4a". Sfortunatamente non c'è modo di risolvere il problema."
Ma se sugli altri sistemi gli MP4 vanno non capisco il significato di questo messaggio. E non capisco anche perchè li chiama mp4a, con l'aggiunta della a, i files sono MP4 regolari.

Mageia 4 cauldron, PCLinuxOS, Linux ManjaroKDE, LinuxMintPetra Cinammon, UbuntuGnome,
FedoraHeinsburg 20.1, Majonix 1.1, LXSElINUXLTS, OpenSuse Bottle, OpenMandriviaLx, Windows 7 Home Premium 64 bit.

Siamo ciò che pensiamo...