Aggiornamenti di Mageia.

6 risposte [Ultimo messaggio]
Ritratto di nonnogs
nonnogs
(Junior)
Offline
Junior
Iscritto: 16/02/2012
Messaggi: 16

Ciao a tutti,sono Giorgio Scubla ed uso il nick nonnogs perchè sono un nonno.Mageia mi piace,in passato tenevo Mandriva tra le mie distro ma non riesco più ad installarla;credo ciò dipenda dall'età del mio pc desktop.Questo è un notebook ma non ho spazio sul disco e così Mageia va in virtuale magnificamente.Il mio problema è costituito da 13 aggiornamenti che mi tiro dietro da parecchio tempo e che non riesco ad installare.Neppure da terminale.Sembra che alla fine della fiera siano tutti legati tra loro e con le dipendenze e la cosa non funziona.

La mia domanda è : capita anche ad altri? è un problema risolvibile ? se si qual'è la soluzione?

Ho postato nelle varie non avendo riconosciuto un settore specifico per il mio problema.

Grazie ed un cordiale saluto a tutti.

Faboski
[=small]L'utopia non e' l'irrealizzabile ma l'irrealizzato[/]

Ritratto di luca64
luca64
(Collaboratore)
Offline
Collaboratore
Iscritto: 24/05/2011
Messaggi: 78

Caro Giorgio,

innanzitutto un benvenuto sul sito Mageiaitalia.org.

A riguardo del tuo problema avrei bisogno di alcune informazioni:
Quale Mageia hai installato ? Con quali pacchetti in aggiornamento hai problemi? Che desktop usi (Gnome, KDE , lxde),penso che con questi dati alla mano con buona volonta' io o qualcun'altro ti possa aiutare.

Ciao Nonno (Spero che al piu' presto anche io vivro' questa magnifica esperienza) Wink

Luca.

Ritratto di nonnogs
nonnogs
(Junior)
Offline
Junior
Iscritto: 16/02/2012
Messaggi: 16

Grazie per il benvenuto ma la controparte delle gioie di essere nonno è la vecchiaia.Che io per il momento sgamo abbastanza bene ma resta vecchiaia.

Dunque : ho installato Mageia 1 che mi sembra fosse e sia tuttora l'unico disponibile.Della 2 ho visto che c'è una beta,quindi è in lavorazione.Correggimi se sbaglio.Uso KDE,con Gnome ho poca simpatia,mi piace abbastanza Xfce ma nella maggioranza delle distro installate ho KDE.Kernel 2.6.38.8.Sotto ho copiato l'elenco degli aggiornamenti che non vanno.Di importante ci vedo il kernel gli altri sono quasi tutti librerie

Questi 13 pacchetti stanno per essere installati:

- gio2.0-32-2.28.8-1-mdv2011.0.i586
- glib2.0-common-2.28.8-1-mdv2011.0.i586
- kdeartwork4-kscreensaver-4.6.5-1-mdv2011.0.i586
- kernel-headers-2.6.39.4-4.2-mdv2011.0.i586
- libcairo2-1.10.2-4-mdv2011.0.i586
- libcryptui0-3.0.2-1-mdv2011.0.i586
- libglib2.0_0-2.28.8-1-mdv2011.0.i586
- libkmbox4-4.6.5-1-mdv2011.0.i586
- libmbox4-4.4.11.1-0.1-mdv2011.0.i586
- libpano13_2-2.9.18-3plf-plf2011.0.i586
- libpixman1_0-0.22.0-1-mdv2011.0.i586
- libuClibc0.9.32-0.9.32-2-mdv2011.0.i586
- zlib1-1.2.5-7-mdv2011.0.i586

Altri 7.5MB di spazio disco saranno utilizzati.

Di seguito hai lo sviluppo dell'aggiornamento.Come vedi è fallito.E' così da diversi giorni e anche adesso c'è l'icona degli aggiornamenti nel pannello

1 transazioni dell'installazione fallite

si è verificato un problema durante l'installazione:

cairo >= 1.7.6 necessario a (installato) libpango1.0_0-1.28.4-1.mga1.i586

cairo >= 1.8.10 necessario a (installato) python-cairo-1.8.10-1.mga1.i586

libcairo.so.2 necessario a (installato) libpango1.0_0-1.28.4-1.mga1.i586

libcairo.so.2 necessario a (installato) plymouth-plugin-label-0.8.3-12.mga1.i586

libcairo.so.2 necessario a (installato) libgtk+-x11-2.0_0-2.24.4-1.mga1.i586

libcairo.so.2 necessario a (installato) libgtk+2.0_0-2.24.4-1.mga1.i586

libcairo.so.2 necessario a (installato) gstreamer0.10-plugins-base-0.10.32-3.mga1.i586

libcairo.so.2 necessario a (installato) gstreamer0.10-plugins-good-0.10.28-1.mga1.i586

libcairo.so.2 necessario a (installato) perl-Cairo-1.70.0-4.mga1.i586

libcairo.so.2 necessario a (installato) perl-Pango-1.221-5.mga1.i586

libcairo.so.2 necessario a (installato) libwnck-1_22-2.30.6-3.mga1.i586

libcairo.so.2 necessario a (installato) perl-Gtk2-1.230.0-5.mga1.i586

libcairo.so.2 necessario a (installato) notification-daemon-0.5.0-2.mga1.i586

libcairo.so.2 necessario a (installato) libxulrunner2.0.1-2.0.1-1.mga1.i586

libcairo.so.2 necessario a (installato) libwebkitgtk1.0_2-1:1.2.7-4.mga1.i586

libcairo.so.2 necessario a (installato) perl-Gtk2-WebKit-0.80.0-5.mga1.i586

libcairo.so.2 necessario a (installato) libvte9-0.26.2-2.mga1.i586

libcairo.so.2 necessario a (installato) perl-Gtk2-Notify-0.50.0-2.mga1.i586

libcairo.so.2 necessario a (installato) perl-Gnome2-Vte-0.90.0-2.mga1.i586

libcairo.so.2 necessario a (installato) libcairomm1.0_1-1.9.8-2.mga1.i586

libcairo.so.2 necessario a (installato) gnome-media-2.32.0-3.mga1.i586

libcairo.so.2 necessario a (installato) libmagick4-6.6.6.10-5.mga1.i586

libcairo.so.2 necessario a (installato) gnome-power-manager-2.32.0-1.mga1.i586

libcairo.so.2 necessario a (installato) python-cairo-1.8.10-1.mga1.i586

libcairo.so.2 necessario a (installato) python-gobject-2.26.0-4.mga1.i586

libcairo.so.2 necessario a (installato) pygtk2.0-2.22.0-4.mga1.i586

libcairo.so.2 necessario a (installato) libgnome-desktop-2_17-2.32.1-1.mga1.i586

libcairo.so.2 necessario a (installato) libgnomekbd4-2.32.0-2.mga1.i586

libcairo.so.2 necessario a (installato) libgtksourceview-2.0_0-2.10.5-1.mga1.i586

libcairo.so.2 necessario a (installato) libmetacity-private0-2.30.3-4.mga1.i586

libcairo.so.2 necessario a (installato) metacity-2.30.3-4.mga1.i586

libcairo.so.2 necessario a (installato) totem-2.32.0-4.mga1.i586

Ti saluto,ciao.

Faboski
[=small]L'utopia non e' l'irrealizzabile ma l'irrealizzato[/]

Ritratto di luca64
luca64
(Collaboratore)
Offline
Collaboratore
Iscritto: 24/05/2011
Messaggi: 78

ciao giorgio,

Da il tuo post, vedo che hai attivati i repo di Mandriva (Mdv= Mandriva; Mga=Mageia.)Tale problema fa si che i pacchetti di Mageia vadano in "conflitto" con quelli di Mandriva), percio' il tuo sistema nota incongruenze tra le versioni dei pacchetti e delle dipendenze. Io penso che forse hai installato dei programmi dai repo di Mandriva, se cosi una volta installati e' consigliabile eliminare i repo Mandriva dalle fonti aggiornamenti, in quanto anche se Mageia e' un fork di Mandriva non sempre le versioni dei programmi coincidono e cio' ti puo' portare qualche giorno a dei casotti nel sistema.

Ciao Luca

Ritratto di nonnogs
nonnogs
(Junior)
Offline
Junior
Iscritto: 16/02/2012
Messaggi: 16

Ciao Luca

in effetti in fase di installazione mi appoggiai a MIB per aggiornare le fonti e nell'elenco ci sono gli ultimi tre :

Http MDV -restricted 32
Http MIB -basic
Http MIB -expert

che ho ricavato da Mandriva,gli altri sono Main,contrib non free,updates backports.A tuo parere è sufficiente eliminare questi tre o devo ricominciare da capo a installare le fonti?

Sono stato tratto in inganno dal fatto che Mageia ha moltissimi punti di contatto con Mandriva.

Ciao Giorgio.

Faboski
[=small]L'utopia non e' l'irrealizzabile ma l'irrealizzato[/]

Ritratto di luca64
luca64
(Collaboratore)
Offline
Collaboratore
Iscritto: 24/05/2011
Messaggi: 78

ciao Giorgio,

Allora devi rimuovere solo tutti i repo Mandriva e PLF che hai installato da gestione fonti aggiornamenti e poi un bel URPMI --auto-select (naturalmente da root)e vedrai che non hai piu' problemi.Un consiglio, leggiti nelle guide mageiaitalia l'ottima guida su urpmi e gestione degli aggiornamenti.

Ciao luca

Ritratto di nonnogs
nonnogs
(Junior)
Offline
Junior
Iscritto: 16/02/2012
Messaggi: 16

Ho dovuto rimuovere tutti i repo installati perchè rimuovendo soltanto quei tre non funzionava.Così ho fatto tabula rasa ed ho reinstallato quelli di Mageia e il risultato è che ne è seguita una paccata di aggiornamenti e di diverse rimozioni.Adesso mi sembra che il sistema sia aggiornato.

Ti ringrazio per la sollecitudine.Ciao.giorgio scubla

Faboski
[=small]L'utopia non e' l'irrealizzabile ma l'irrealizzato[/]